Gutenberg en Cloudflare

Update (11/8/2018): Het hieronder beschreven issue zou zijn opgelost.
Update (13/8/2018): Behalve dan wanneer je achter die proxyserver zit. Jammer.

Toen ik recent op een mijner websites Gutenberg, de nieuwe ‘blokeditor’ voor WordPress, eens aan de tand wilde voelen, kreeg ik bovenaan het editor-scherm continu Updating failed te zien. Best vervelend.

Cloudflare blijkt – na heel wat zoekwerk – de oorzaak, ondanks berichten dat het probleem verholpen zou zijn. Als jij dus met eenzelfde melding wordt geconfronteerd én op het Cloudflare-dashboard onder Firewall een heleboel events ziet met Rule ID WP0025B, dan ken je nu de oorzaak.

De oplossing: je IP-adres toevoegen aan Cloudflares whitelist. Al is dat niet eenvoudig als je WordPress regelmatig vanop meerdere locaties (en van achter een proxyserver) benadert. Voor mij is het in ieder geval geen oplossing.

Nog even geen Gutenberg, dus. (Mogelijk kan ik ook zonder Cloudflare, hoor, maar ik ben sowieso niet de enige de graag van de dienst gebruikmaakt.) Beetje jammer dat de voorlopig matig onthaalde plugin straks – d.i. in versie 5.0 – automatisch van elke WordPress-installatie deel uitmaakt.

GitHub Updater

GitHub Updater is een WordPress-plugin die niet in de officiële WordPress-repository maar op GitHub leeft en WordPress-gebruikers toelaat om supergemakkelijk andere GitHub-plugins en ‑themes te installeren en bij te werken en op die manier misschien wel een van de handigste plugins ever.